/
カテゴリー

解説

問題

トポロジ&IPアドレス表

あなたは友人とともに自宅のネットワーク環境を整えています(図参照)。友人はCSR2,CSR3を設定しました。
あなたはCSR1を操作しネットワークを完成させなければなりません。
必要な設定は以下の3つです。

1.CSR2とOSPFネイバーを確立し、経路情報を交換する

  • area : 0
  • ネットワークマスク : /24
  • Helloインターバル : 10
  • Dead インターバル : 40
  • 認証なし
    CSR2へdefault route のアドバタイズを行う

2.CSR3とBGPネイバーを確立し、経路情報を交換する

  • local AS : 65001
  • ネイバーIP : 10.0.0.3
  • remote AS : 65002
  • 認証なし

3.OSPFで学習した経路のうち、10.2.1.0/24のみをEBGPに再配布する

あなたは1,2の設定作業を終えたときに、CSR2とOSPFネイバーが、CSR3とEBGPネイバーが確立できていないことに気が付きました。
設定ミスや、パラメータについて友人と正しく共有できていなかったがあった等、様々な可能性があります。
友人は現在深い眠りについているので、話を聞くことができません。
もし異なっていると思われるパラメータが存在するならば、CSR1の設定を修正してネイバー確立を試みてください。

・トラブルシューティングのヒント
Cisco機器ではトラブルシューティングにdebugコマンドを使用する機会が多くあります。
1のトラブルについて、debugコマンドを使用し状況把握に努めてください
telnet接続時にdebugコマンドの出力を確認するには、特権モードでterminal monitorを実行してください。
全てのdebugの出力を止めるには no debug allを使用します。

CSR2,CSR3については設定を行うことはできませんが、CSR1からtelnetを行うことによって show ip route など一部のshowコマンドを実行することができます。

(1) 本問題ではCSR2,CSR3に接続されているネットワークを表現するためにLoopback interfaceを使用しています。
(2) CSR2,CSR3からCSR1へアドバタイズされないルートが存在しますが、不具合ではありません。
(3) 本問題ではvnc serverをPPPoEルータとみなしています。

解説

1と2について順序関係はありません。
3については1と2のトラブルを解決後に構築が行なえます。

1. CSR2とOSPFネイバーを確立し、経路情報を交換する

トラブルは、設定を行ったにもかかわらずCSR2とのOSPFネイバーが確立できないという内容です。
CSR1の設定ミスやCSR2とのパラメータの不一致が考えられます。(ネイバー確立の条件についてはぜひ調べてみてください)
CSR1のOSPFの設定を確認すると以下のようになっています。

router ospf 1
 passive-interface default
 no passive-interface GigabitEthernet2
 network 192.168.1.0 0.0.0.255 area 0
 default-information originate

networkコマンドが設定されており、no passive-interfaceとなっていることからGigabitEthernet2からOSPF Helloは送信されていそうです。
次にHelloが送信されているかを確認します。
問題文にあるように、telnet接続時にdebugの出力を得るにはterminal moniorを実行してください。

 
csr1#debug ip ospf packet 
OSPF packet debugging is on
csr1#
*Dec 15 15:08:59.110: OSPF-1 PAK  : Gi2:  IN: 192.168.1.2->224.0.0.5: ver:2 type:1 len:44 rid:2.2.2.2 area:0.0.0.0 chksum:2617 auth:0
csr1#
*Dec 15 15:09:00.473: OSPF-1 PAK  : Gi2: OUT: 192.168.1.1->224.0.0.5: ver:2 type:1 len:44 rid:1.1.1.1 area:0.0.0.0 chksum:28F3 auth:0
csr1#no debug all

Helloは送信されており、CSR2のHelloを受信していることも確認できます。
ではHelloを送受信でどのようなことが起こっているのでしょうか。

csr1#debug ip ospf hello 
OSPF hello debugging is on
csr1#
*Dec 15 15:11:05.759: OSPF-1 HELLO Gi2: Rcv hello from 2.2.2.2 area 0 192.168.1.2
*Dec 15 15:11:05.759: OSPF-1 HELLO Gi2: Mismatched hello parameters from 192.168.1.2
*Dec 15 15:11:05.759: OSPF-1 HELLO Gi2: Dead R 12 C 40, Hello R 3 C 10 Mask R 255.255.255.252 C 255.255.255.0
csr1#no debug all

debugの出力からHello interval/Dead interval、ネットワークマスクがの不一致が確認できます。
これがネイバー確立を行えなかった原因です。
これらを修正するコマンドは以下です。

interface GigabitEthernet 2 
 ip address 192.168.1.1 255.255.255.252
 ip ospf hello-interval 3
 ip ospf dead-interval 12

上記の設定を行うとネイバーが確立できます。

csr1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:09    192.168.1.2     GigabitEthernet2
csr1#

しかし問題はここで終わりません。
CSR2にログインし、ルーティングテーブルを確認します。

 
csr2>show ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        10.2.1.0/24 is directly connected, Loopback1
L        10.2.1.1/32 is directly connected, Loopback1
C        10.2.2.0/24 is directly connected, Loopback2
L        10.2.2.1/32 is directly connected, Loopback2
C        10.2.3.0/24 is directly connected, Loopback3
L        10.2.3.1/32 is directly connected, Loopback3
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, GigabitEthernet1
L        192.168.1.2/32 is directly connected, GigabitEthernet1
csr2>

CSR2へdefault route のアドバタイズを行うはずが、CSR2にはGateway of last resort is not setと出力されアドバタイズがされておりません。
なぜdefault-information originateという設定が行われているのにアドバタイズがされないのでしょうか。
実はCSR1にもデフォルトルートがないため、アドバタイズが行われないのです。

csr1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        10.0.0.1/32 is directly connected, Loopback1
O        10.2.1.0/24 [110/2] via 192.168.1.2, 00:06:00, GigabitEthernet2
O        10.2.3.0/24 [110/2] via 192.168.1.2, 00:06:00, GigabitEthernet2
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet1
L        192.168.0.1/32 is directly connected, GigabitEthernet1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, GigabitEthernet2
L        192.168.1.1/32 is directly connected, GigabitEthernet2
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/30 is directly connected, GigabitEthernet3
L        192.168.2.1/32 is directly connected, GigabitEthernet3
csr1#

これを解決するには以下の2通りの方法が考えられます。
1.CSR1にstatic route(ip route 0.0.0.0 0.0.0.0 192.168.0.254)でデフォルトルートを作成する
2.CSR1のOSPFにdefault-information originate alwaysと設定しデフォルトルートの有無にかかわらずアドバタイズを行う
構築のゴールはデフォルトルートがアドバタイズされることなので、どちらの方法でも構いません。
CSR2のルーティングテーブルが以下のように出力されればOKです。

 
csr2>show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

O*E2  0.0.0.0/0 [110/1] via 192.168.1.1, 00:02:26, GigabitEthernet1
      10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        10.2.1.0/24 is directly connected, Loopback1
L        10.2.1.1/32 is directly connected, Loopback1
C        10.2.2.0/24 is directly connected, Loopback2
L        10.2.2.1/32 is directly connected, Loopback2
C        10.2.3.0/24 is directly connected, Loopback3
L        10.2.3.1/32 is directly connected, Loopback3
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, GigabitEthernet1
L        192.168.1.2/32 is directly connected, GigabitEthernet1
csr2>

2. CSR3とBGPネイバーを確立し、経路情報を交換する

トラブルは、設定を行ったにもかかわらずCSR3とのBGPネイバーが確立できないという内容です。

csr1#show ip bgp summary 
BGP router identifier 10.0.0.1, local AS number 65001
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.3        4        65002       0       0        1    0    0 never    Idle
csr1#

設定ミスやCSR3とのパラメータの不一致が考えられます。(ネイバー確立の条件についてはぜひ調べてみてください)
CSR1のBGPの設定を確認すると以下のようになっています。

router bgp 65001
 neighbor 10.0.0.3 remote-as 65000
 neighbor 10.0.0.3 update-source Loopback1

CSR1のルーティングテーブル(上記参照)では10.0.0.3のNext HopがCSR3のGigabitEhternet1になっていません。
したがって10.0.0.3へは通信が行えません。

csr1#ping 10.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
csr1#

これを解決するためにはstatic routeで経路情報を追加します。

 csr1(config)#ip route 10.0.0.3 255.255.255.255 192.168.2.2
csr1(config)#end
csr1#ping 10.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
csr1#

しかしまだ問題は解決しません。
CSR3にアクセスして実行できるコマンドを確認すると、show ip protocolsshow ip bgp summaryなどがあります。

 
csr3>show ip bgp summary 
BGP router identifier 10.3.20.1, local AS number 65000
BGP table version is 2, main routing table version 2
1 network entries using 248 bytes of memory
1 path entries using 136 bytes of memory
1/1 BGP path/bestpath attribute entries using 280 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 664 total bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4        65001       0       0        1    0    0 never    Active
csr3>

上記の出力確認するとCSR3のlocal AS numberが65000であることがわかります。
ネイバーの宛先としてCSR1のループバックを指定していることも確認できます。
以下の設定で解決を試みます。

router bgp 65001
 neighbor 10.0.0.3 remote-as 65000
 neighbor 10.0.0.3 update-source loopback 1

まだ解決には至りません。
CSR1とCSR3のASは異なる値であるため、EBGPとなります。
EBGPのデフォルトのTTLは1であるため、Loopbackまでパケットが到達しないのです。
これを解決するためは以下のような設定となっていればOKです。

router bgp 65001
 neighbor 10.0.0.3 remote-as 65000
 neighbor 10.0.0.3 update-source loopback 1
 neighbor 10.0.0.3 ebgp-multihop 2

以下確認のコマンドです。

csr1#show ip bgp summary 
BGP router identifier 10.0.0.1, local AS number 65001
BGP table version is 2, main routing table version 2
1 network entries using 248 bytes of memory
1 path entries using 136 bytes of memory
1/1 BGP path/bestpath attribute entries using 280 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 688 total bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.3        4        65000       5       4        2    0    0 00:00:06        1
csr1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.0.0.1/32 is directly connected, Loopback1
S        10.0.0.3/32 [1/0] via 192.168.2.2
O        10.2.1.0/24 [110/2] via 192.168.1.2, 00:55:08, GigabitEthernet2
O        10.2.3.0/24 [110/2] via 192.168.1.2, 00:55:08, GigabitEthernet2
B        10.3.10.0/24 [20/0] via 10.0.0.3, 00:00:16
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, GigabitEthernet1
L        192.168.0.1/32 is directly connected, GigabitEthernet1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, GigabitEthernet2
L        192.168.1.1/32 is directly connected, GigabitEthernet2
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/30 is directly connected, GigabitEthernet3
L        192.168.2.1/32 is directly connected, GigabitEthernet3
csr1#

3. OSPFで学習した経路のうち、10.2.1.0/24のみをEBGPに再配布する

こちらはトラブルではなく構築問題となります。
解法はいくつも存在します。
ここでは一例としてroute-mapを使用した再配送の設定を示します。

router bgp 65001
 redistribute ospf 1 route-map FromOspf
 !!! 省略 !!!
!
access-list 1 permit 10.2.1.0 0.0.0.255
!
!
route-map FromOspf permit 10 
 match ip address 1
!

CSR3のルーティングテーブルが以下のようになっていればOKです。

 
csr3>show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
S        10.0.0.1/32 [1/0] via 192.168.2.1
C        10.0.0.3/32 is directly connected, Loopback1
B        10.2.1.0/24 [20/2] via 10.0.0.1, 00:00:25
C        10.3.10.0/24 is directly connected, Loopback2
L        10.3.10.1/32 is directly connected, Loopback2
C        10.3.20.0/24 is directly connected, Loopback3
L        10.3.20.1/32 is directly connected, Loopback3
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/30 is directly connected, GigabitEthernet1
L        192.168.2.2/32 is directly connected, GigabitEthernet1
csr3>

講評

ルーティングの実技問題として本問題を出題させていただきました。
解答をしてくださった方々の得点率は高かったので作門者としては嬉しい限りです。
しかしながら全問題中で解答率は一番低い問題となってしまいました。
ネットワークよりもサーバやプログラミングの分野が得意な方が多く参加された結果なのかと感じました。

ちなみにですが、本問題で曲者となったのはトラブル1のデフォルトルートのアドバタイズです。
ネイバーが構築できた後に、CSR2のルーティングテーブルの確認を失念してしまった方が多かったのではないかと思います。

本問題がきっかけでネットワーク分野により興味を持ってくださる方がいらっしゃれば幸いです。

 /
カテゴリー

解説

問1

下の表についてSNMPに関する記述として最も正しい選択肢を答えてください。

◆問1. 解説◆

【正答:(d)】

一次予選でも出題されていたSNMPで用いられるポート番号に関する問題を発展させた問題です。

・ポーリング時(Manager→Agent)では宛先ポート番号として161/UDPが使用
・トラップ時(Agent→Manager)では宛先ポート番号として162/UDPが使用
・SNMPでは「MIB」という管理情報を基にして管理対象機器の状態を把握
・SNMPv2c以降では「inform」という再送機能が実装

SNMPはUDPでやり取りされるためNWに余計な負荷をかけないという利点がある反面、信頼性が劣るという欠点があります。
特にトラップ通知時にはManager側で正常に受信が出来なかった場合、通知内容を把握することが出来なくなってしまいます
(ポーリング時の受信異常発生時には無応答状態を把握することが可能)

この欠点を補うためにSNMPv2c以降では「inform」という再送機能を実装した通知を使用することが出来ます。
inform通知ではManagerが通知を正常に受信した場合はAgentに応答をするという仕組みになっており、AgentでもManagerが通知を正常受信したかどうかを把握することが可能になっています。

https://www.infraexpert.com/study/tcpip21.html
https://www.infraexpert.com/study/tcpip21.5.html

問2

次のOIDを指定した場合の動作内容について最も正しい選択肢を答えてください。

 OID: .1.3.6.1.4.1.9.9.109.1.1.1.1.8

(a) Juniper社製品の再起動が可能

(b) 全てのルータ製品の直近1分間のCPU利用率が取得可能

(c) 全てのL2スイッチ製品の直近5分間のCPU利用率が取得可能

(d) Apple社製品の直近1分間のCPU利用率が取得可能

(e) Cisco社製品の直近5分間のCPU利用率が取得可能

(f) NEC社製品のバージョン情報が取得可能

◆問2. 解説◆

【正答:(e)】

OIDについて調べればすぐに正答を得ることが出来たと思いますが、MIBの構造についてはしっかり把握しておきましょう。特に拡張MIBでは各ベンダ固有のツリー情報を設定することが可能です。
詳細は各ベンダにて公開されている情報から確認出来ます。

https://www.cisco.com/c/ja_jp/support/docs/ip/simple-network-management-protocol-snmp/15215-collect-cpu-util-snmp.html

問3

NW上の機器状態を把握する方法としてSNMPとSYSLOGを比較した場合について正しい説明の選択肢を答えてください
(複数回答可)

(a) SNMPとSYSLOGのどちらも管理対象機器の設定変更まで実施することが可能である

(b) 標準機能でRSAなどの暗号化技術に対応したバージョンが存在するSNMPの方がセキュリティが高い

(C) SYSLOGでは指定した優先度以上のメッセージのみ送信するように設定することが可能である

(d) 回線エラー発生数やCPU状態などの性能監視をしたい場合にはSYSLOGが適している

(e) SNMPの各バージョンは混在して設定することが出来ない

(f) 上記の選択肢の中に正しい説明はない

◆問3. 解説◆

【正答:(c)のみ】

(a) SYSLOGでは管理対象機器の設定変更まで実施することは出来ません
(b) SNMPv3ではセキュリティが強化されていますが、RSAには対応していません(DESもしくはAES)
(c) 正しい記述です
(d) SYSLOGよりもSNMPを用いた方が適しています
(e) SNMPv1,SNMPv2c,SNMPv3は混在して設定することが可能です

 /
カテゴリー

解説

問題内容

  • 背景
    • 最近、某社では大規模なネットワーク構成の変更が行われ、有識者から十分な情報共有がなされないまま、これまでとは異なる担当者によるネットワーク設定がされた。数日後、複数の利用者から「昔はコンテンツが見れていたのに!」とクレームが入った。
      • PC_A利用者「https://icttoracon.net/trial/testにつながらないぞ!」
      • PC_B利用者「https://icttoracon.net/trial/testにつながらないぞ!」
      • PC_C利用者「https://icttoracon.net/test/trialにつながらないぞ!」

      担当者へのヒアリング結果を見ながら、それぞれの利用者がつながらない原因として最も考えられるものを下記から選べ。
      なお、名前解決は正しく行われており、かつ、コンテンツはすべてbackendサーバに配置されているものとする。

  • ネットワーク構成図

  • 担当者ヒアリング

    • 担当者A曰く「nginxのiptablesはこう設定したよ」
        iptables –A INPUT –s 192.168.1.0/255.255.255.0 –p tcp ––dport 443 –j ACCEPT
        iptables –A INPUT –s 192.168.2.0/255.255.255.0 –p tcp ––dport 80 –j ACCEPT
        iptables –A INPUT –s 192.168.3.0/255.255.255.0 –p tcp ––dport 443 –j ACCEPT
        iptables –A INPUT –j DROP
    
    • 担当者B曰く「nginxのconfファイルはこう設定したよ」
    (一部抜粋)
           location ~/trial/.* {
             allow  192.168.2.0/24;
             deny all;
             proxy_pass https://10.0.0.1;
           }
    
           location ~/test/.* {
             allow 192.168.3.0/24;
           }
    

解答選択

  1. iptablesの設定でアクセス拒否されている
  2. nginxの設定でアクセス拒否されている
  3. nginxのproxy設定が間違っている
  4. 上記のいずれでもない

解答・解説

それぞれの利用者からのリクエストパケットがnginxにて処理される順序として、まずはiptablesでfilterが参照され、許可されたものがnginxのconfによって処理を判断されます。proxyの処理についても注意して見る必要があります。
上記に沿ってそれぞれの問題を見ていくと、

  • PC_A利用者: 2.が正解。nginxのlocation設定では、PC_Bセグメントのみ許可されている
  • PC_B利用者: 1.が正解。PC_Bのセグメントは80番portのみ許可されている
  • PC_C利用者: 3.が正解。iptablesで許可され、nginxのconfファイルでセグメントも許可されるが、location /testに”proxy_pass https://10.0.0.1″の記載が抜けている。(パスがhttps://icttoracon.net/test/trialになっていることに注意)

講評

本設問は、ほとんどのチームがチャレンジしてくれました。
どちらかといえば解きやすい問題で、全問正解するチームも多かったです。
設問のようなトラブルは極端な例ですが、現実世界でも「コンテンツが見れない」などの不具合では、(filter設定に限らず)複数箇所で複合的な問題が発生しているケースが多々あります。
経路設定は正常か、pingは通るか、src IP/dst portを変えるとどうか、など、ネットワークで起きていることを想像しながらトラブルシュートすることが重要です。

 /
カテゴリー

解説

Q1.VLAN

  • 問題文

VLANに関する記載のうち、正しいものを選べ

  • 選択肢
    • A. VLANが異なるノードは同一のL2ブロードキャストドメインに所属していない
    • B. VLANはIPパケットにVLANIDが付与され、ルータにおいて同一のVLANIDを持つネットワークに対してフレームが転送される。
    • C. 802.1qではセキュリティ上の問題から、Taggedに設定されているポートではすべてのフレームにVLANidが必須であり、VLANタグのついていない受信フレームはすべて破棄しなければならない
    • D. 802.1qでは10bitのVLAN識別子に代わって、4byte VLANを用いる。これには「.<16bitの識別子」というvlandotという表記が標準的に用いられている。
  • 正解 : A

  • 解説

    VLANはコリジョンドメインを分ける機能であるためAが正しい。
    VLANはEtherフレームに付与されるタグのVLANIDによって、スイッチにおいて適切に転送される。このためB誤り。(また、ルータはVLANIDではなくルーティングテーブルによってパケットを転送します)。
    Taggedポートであっても、UntagedのフレームはNative VLANの設定があればスイッチは処理することできる。このため、Cは誤り。
    VLANは802.1qで定義されるプロトコルであり、10bitで表現されるIDをもつ。このため、Dは誤り。

Q2.ルーティング

  • 問題文
    以下の文章のうち【誤って】いるものを選べ

  • 選択肢

    • A. BGPにおいてholddown timerが異なるルータ間ではpeerが確立できない
    • B. OSPFにおいてhello intervalの異なるルータ間ではpeerが確立できない
    • C. OSPFにおいてdead intervalの異なるルータ間ではpeerが確立できない
    • D. OSPFにおいてMTUが異なって設定されているルータ間ではpeerが確立できない
  • 正解 : A

  • 解説

    BGPにおいて、holddown timerは値が短い方が用いられて、Peerは確立できる。このため、Aが誤った記述であり正解の選択肢。

    OSPFにおいて、選択肢に上げたtimerやMTUは一致しないければならない。このため、B,C,Dは正しい記述であるため誤った選択肢。

Q3.BGP

  • 問題文
    Ciscoルータでは、BGPセッションの保護のため、以下のような設定をすることができる
R1(config)# router bgp 64496
R1(config-router)#neighbor 198.51.100.1 remote-as 64497
R1(config-router)#neighbor 198.51.100.1 password ICTSC

このとき、ルータ間のパケットはどのように保護されるか。

  • 選択肢
    • A. BGPメッセージに対するMD5署名が行われ、不正なメッセージからセッションを保護する
    • B. 両ルータ間で動的なIPSecトンネルがに確立され、メッセージの内容が保護される
    • C. BGPセッションの確立時にチャレンジアンドレスポンスでの認証が行われ、不正なセッションの確立を防ぐ
    • D. BGPセッションの確立時にHTTPSが確立され、メッセージの内容が保護される。
  • 正解 : A

  • 解説:

    RFC 2385のMD5 Digestを用いたセッション保護に関する問題。neighbor x.x.x.x passwordコマンドはこの標準に従い、BGPルータ間のセッションを署名し、第三者がTCPセッションを乗っ取ったり、成り済ますこと確立を低減させる。このため、Aは正しい。

    B,C,Dの選択肢のように通信路事態は暗号化されず、あるいは、確立時のみに認証を行う機能ではない。

Q4.OSPF

  • 問題文

2台のルータ R1 <-> R2間は192.168.0.0/30のネットワーク上で接続されており、お互いに、10.1.1.1/32がlo0に割り当てられている。 また、ルータ間ではOSPFが確立されており、R2はlo0に付与された10.1.1.1/32のアドレスをR1に広告している。 この経路を受信したR1の動作として正しいものを選べ。 (すべてのルータにおいてAD値は変更されていないものとする。)

  • 選択肢
    • A. R1はOSPFで経路を受信するが、自身のConnectedアドレスとして10.1.1.1/32を保持するため、RIBにはインストールされない。
    • B. R1は自身の持つアドレスをR2から受信すると、OSPFはループを防止するため該当I/Fを閉塞する。
    • C. R1はOSPFで経路を受信するため、この経路をConnectedアドレスより優先し、RIBにインストールする。
    • D. R1はConnected経路としてこの経路を保持しているが、ループバックアドレスは特殊なアドレスであるため、R1のRIBにインストールされる。
  • 正解 : A

  • 解説:

    複数のプロトコルで同じ経路が存在する場合のルータの動作およびOSPFの動作に関する問題。

    Connected経路と同様のOSPF経路を受信すると、AD値の低いConnected経路が採用される。

    OSPFは自身の持つ経路と同じ経路を受信してもI/Fを閉塞する機能を少なくとも標準的には有さない。また、OSPFではループバックアドレスを識別する情報は伝搬されない。

Q5.物理(光)

  • 問題文

あなたの友人のBさんはルータ間を100G-LR4で接続しようとしている。 Bさんから以下のような相談の電話を受けた。

先輩から、「光がどっちのケーブルから出ているか注意してつなぐんだよ」とアドバイスされたから光レベルメータを持っていたんだ。この光レベルメーターは850/1310/1550の3つの光波長が測定できるんだ。

100G-LR4だから850nmの波長を測定するモードに変更して、片方の芯線をメータに接続したら、最初のうちはいろんな数字が安定していなかったんだけど、最後は、0.00dBmという表示になったんだ。
0ということはこっちからは光が出ていないのかな?どうすればいいんだろう?

  • 選択肢
    • A. その芯線から光が出ている。ただし、100G-LRではOバンドの波長が用いられているため、測定対象の波長を変更して再測定してから接続することが好ましいとアドバイスする。
    • B. 0.00dBmということは一切の光の出力がされていない芯であり、もう一方の芯線から光が出ていると推定されると回答する。
    • C. 100G-LRでは不可視光が用いられているため、どちらから光が出ているかを光レベルメータで確認することができない。不可視光領域のパワーを確認するためにスペクトルアナライザを用いるべきだと提案する。
    • D. 100G-LR4は高速化のために両芯で光を送出するため、OTDRを用いて光パルス試験を行い、パルスに含まれるIDを読み取らなければどのように接続を行えばよいかわからないと回答する。
    • E. 100G-LR4はシングルモードファイバの零分散波長を用いているため、一切のエネルギーを使わずに多量のデータを送信できるため、0dBmの表示は正しい。
  • 正解 : A

  • 解説

    Aが正解。1mWの光が出力されている。ただし、100G-LR4の波長は850nmではなくOバンド帯である。このため、現状のモードでは、光パワーが接続に適切な値であるかを判定できない。このため、選択肢の通り測定対象の波長を変更することが好ましいと解答するのが最も適切である。

    0.00dBmの光出力は1mWを表す。このため、Bは誤り。

    100G-LR4は不可視光を用いてはいるが、1芯のみを送出に用いるため、図の測定で充分である。特にスペクトルアナライザを用いなくてよい。Cは誤り。

    100G-LR4は4波の光を変調多重し、1芯で伝送する。OTDRの光パルス試験は芯線内のIDを読み取るものではない。Dは誤り。

Q6.無線

  • 問題文

無線に関する記述のうち、正しい言葉の組み合わせを選べ

電波は空気中の水蒸気や酸素の分子などにエネルギーを吸収され、
伝搬中に(a)。また、雨天の際、雨滴では、(b)が生じる。
減衰量はほぼ降雨量に比例し、電波の波長が短いほど(c)する。
  • 選択肢
    • A. a.減衰する b. 熱損失や散乱損失 c.増加
    • B. a.減衰する b. ミー散乱 c.増加
    • C. a.増幅する b. 熱損失や散乱損失 d.低下
    • D. a.減衰する b. 四光波混合 c.増加

正解 : A or B (問題部不十分のため2つが正解)

  • 解説

本問題に際しては、長波の電波に関して出題を予定しており、b=ミー散乱をNGとする問題とする予定だったのですが、この記載を漏らしてしまい、不適切な出題となりました。このため、2つの選択肢を回答と扱いました。

各空欄についての解説は以下の通り。

a:エネルギーを吸収されるのであるから減衰する

b:エネルギーが吸収されるか、散乱して、光は弱くなる。この際の散乱として、波長に対して粒子が十分に大きい場合には回折散乱、波長と粒子が同程度の場合はミー散乱、粒子が十分に小さい場合はレイリー散乱が発生する。(本設問では、散乱損失、ミー散乱ともに正解)

c: ある程度の波長までは徐々に減衰する(=減衰量が増える)。

 /
カテゴリー

解説

Q1. 192.0.2.192/25 のネットワーク内でホストに割り当て可能なIPアドレスの個数の総数はいくつか

  • 125個
  • (正解)126個
  • 127個
  • 128個

解説

192.0.2.192/25のサブネットには128個のIPアドレスがあるが、そのうちホストに割当可能なアドレスは先頭のネットワークアドレスと末尾のブロードキャストアドレスを除いた数になるため、128-2=126個割当可能が正解となる。

Q2. ARPについて述べた次の文章のうち、正しいものはどれか

  • (正解)IPアドレスからMACアドレスを得るためのプロトコル
  • IPアドレスからホスト名(ドメイン名)を得るためのプロトコル
  • MACアドレスからIPアドレスを得るためのプロトコル
  • ホスト名(ドメイン名)からIPアドレスを得るためのプロトコル

解説

ARPはIPアドレスからMACアドレスを得るためのプロトコルである。選択肢2はDNS(逆引き)、選択肢3はRARP(Reverse ARP)、選択肢4はDNS(正引き)である。

Q3. DHCPリレーエージェントが必要になる場合、利用される機器は次のうちどれか

  • スイッチングハブ
  • ブリッジ
  • リピータ
  • (正解)ルータ

解説

DHCPのパケットは基本的にブロードキャストでやりとりされるため、ブロードキャストドメインを超えて通信する場合にはルータの機能であるリレーエージェントを利用する方法がある。リピータ・スイッチングハブ・ブリッジはレイヤ1・レイヤ2のデバイスであるため、リレーエージェントが無くてもDHCPは利用可能である。

Q4. AS(自律システム)に関する記述について、正しいものは次のうちどれか

  • 経路情報に付加されたパス情報を使用し、ポリシに基いて経路を選択するパスベクタ方式のプロトコルである
  • ルータ同士の最短距離を木構造のトポロジに分解し、Helloプロトコルによって隣接関係を確立する。
  • (正解)同一の管理ポリシによって管理されるネットワーク群であり、2byteまたは4byteの番号によって識別される。
  • リンクステート型の共通プロトコルで、ルーティング情報を相互に交換するルータの集合である。

解説

ASの意味は正解選択肢の通りである。選択肢1はBGPの説明、選択肢2はOSPFの説明、選択肢4はOSPFドメインの説明である。

Q5. 次の文章のうち、光通信で利用されるWDM技術について述べたものはどれか

  • 周波数分割を利用し、多数のデバイスの信号を1本のケーブルに多重する技術である。
  • 時分割を利用し、多数のデバイスの信号を1本のケーブルに多重する技術である。
  • (正解)波長分割を利用し、多数のデバイスの信号を1本のケーブルに多重する技術である。
  • 符号分割を利用し、多数のデバイスの信号を1本のケーブルに多重する技術である。

解説

WDM(Wavelength Division Multiplexing)技術は、光ファイバに複数の波長の光を合波して入射し、受信側で分波して各波長を取り出すことで1本のケーブルに多数のデバイスの信号を多重する技術である。周波数分割はFDM(Frequency)、時分割はTDM(Time)、符号分割はCDM(Code)と呼ばれる。

Q6. インターネットプロトコルの特徴について述べた文章のうち、正しいものはどれか

  • OSI参照モデルのレイヤ3に相当し、コネクション型の通信プロトコルである。
  • IPデータグラムの信頼性を高めるため、再送や順序保証などの制御に関する仕組みを持つ。
  • (正解)下位層であるデータリンク層のMTUに合わせてIPデータグラムをフラグメンテーションし、リアセンブリする仕組みを持つ。
  • IPv4ヘッダのアドレスフィールドには、下位層との整合性を保つため、送信元・宛先MACアドレスが挿入される。

解説

選択肢1として、IPはコネクション型の通信プロトコルではなく、コネクションレス型である。選択肢2として、再送や順序保証を行うのは上位層のTCPであり、IPではない。選択肢4として、IPv4ヘッダのアドレスフィールドにMACアドレスが挿入されることはない。よって選択肢3が正解。

Q7. IPv6について説明した文章のうち、誤っているものはどれか

  • (正解)IPv6のヘッダ長は40byteに固定され、拡張ヘッダはペイロード部分に書き込まれる。
  • IPv6のアドレスサイズは128bitである。
  • ブロードキャストアドレスは定義されていない。
  • ネットワークインタフェースには、複数のIPv6アドレスを割り当てることが可能である。

解説

本問題は、予選参加者からの問い合わせにより正答となる選択肢(誤っている文章)も解釈によっては正答となり得るため、問題不成立とし全チーム一律正解とした。出題の意図として、選択肢1の ペイロード とは本来送信したい上位層から受け取ったアプリケーションデータを想定しており、例えばICMP Echo Requestのデータ部などにIPv6のヘッダが挿入されることは無い等として誤った文章として出題した。

だが、IPv6のRFC2460の文書中にはNote that any extension headers [section 4] present are considered part of the payload, i.e., included in the length count. とあり
– IPv6にPayloadの定義はない
– IPv6のPayload Lengthは(データ部分) + 拡張ヘッダ長
と解釈できることから、Payload = データ部分 + 拡張ヘッダとしての説明が成り立ち、問題不成立となった。その他選択肢は正しい内容である。

Q8. イーサネットについて述べた次の文章のうち、誤っているものはどれか

  • MACアドレスは、I/Gビットが0のユニキャストアドレスと1のマルチキャストアドレスがある。
  • イーサネットでは後続するフレームがあっても、少なくとも96bitの転送に要する時間のIFGと呼ばれるアイドル状態を設ける必要がある。
  • CSMA/CDでは衝突を検知すると、決められた一定の時間だけ待ってから再送を行う。
  • (正解)CSMA/CAでは衝突を検知すると、決められた一定の時間だけ待ってから再送を行う。

解説

引っかかりやすい内容で、内容として誤っているのは選択肢4である。CSMA/CAはCollision Avoidance(衝突回避)型であり、送信の前に待ち時間を毎回挿入する。衝突を検知するのはCSMA/CDであり、万が一検出したら即座に通信を中止し待ち時間を挿入する。

Q9. シングルモード光ファイバを利用するメディアは、次のうちどれか

  • 1000BASE-SX
  • 10GBASE-FX
  • (正解)100GBASE-ER4
  • 40GBASE-SR4

解説

選択肢1と4はマルチモード光ファイバを利用する。選択肢2はそもそも規格として存在しない。よって選択肢3が正解である。

Q10. IEEE802.11の無線LANについて述べた次の文章のうち、正しいものはどれか

  • アドホックモードでアクセスポイントが複数ある場合は、一般に、アクセスポイント間をイーサネットなどで接続し、ローミング機能を持たせている。
  • CSMA/CA方式とCSMA/CD方式との違いは、CSMA/CA方式は衝突が発生しないようフレームを送信状況を監視する「衝突検知」仕様であるのに対し、CSMA/CD方式は衝突の発生を前提とした「衝突回避」仕様である。
  • MACアドレスフィルタリング方式では、MACアドレスが暗号文で送信されるため、盗聴や詐称によるなりすましの接続はできない。
  • (正解)無線LANのネットワークをグループ化するための識別符号であるESS-IDを用いたアクセスポイントへの接続制限の設定は、電波をモニタすることで盗聴可能であるなど、セキュリティ上の弱点がある。

解説

選択肢1で誤っている点は、アドホックモードではなくインフラストラクチャモードである。選択肢2は衝突検知と衝突回避の説明が逆である。選択肢3は、MACアドレスフィルタリングの説明が間違っており、MACアドレスが暗号化されるわけではない。よって選択肢4が正解。

Q11. コイルに交流電圧をかけたとき、流れる電流について述べた次の文章のうち、正しいものはどれか

  • 電流の位相は電圧に対して45度進む
  • 電流の位相は電圧と同じ位相である
  • (正解)電流の位相は電圧に対して90度遅れる
  • 電流の位相は電圧に対して60度遅れる

解説

コイルに流れる電流は電圧の位相に対して90度遅れる。位相が遅れると力率が悪くなるため、コンデンサを並列に接続して位相を進める措置が取られる。そのため、変電所や大電力需要家には進相コンデンサと呼ばれるコンデンサが力率改善のために設置されることがある。

Q12. スペクトラムアナライザでとある周波数を測定したとき、0dBmと表示された。この時、受信電力はいくつか。(単位:W=ワット)

  • 0mW
  • (正解)1mW
  • -1mW
  • 10mW

解説

dBmは電力を1ミリワット(mW)を基準値とするデシベル(dB)の値で表した単位である。よって、0dBmの対数表現を真値に変換すると1mWとなる。光ネットワークの現場で、パワーメータを接続して受光パワーを測定することがある。 この時間違っても「0dBmと表示されています。光が出ていません」 と言ってはいけない。

Q13. 電子レンジによって最も妨害を受ける周波数帯は、次のうちどれか

  • 920MHz帯
  • (正解)2.4GHz帯
  • 5.6GHz帯
  • 1.2GHz帯

解説

電子レンジはマグネトロンから2.45GHz帯の大電力電波を庫内に放射し、物質の分子を振動させることで温める家電である。同じく2.4GHzのISMバンドを利用する無線LANが最も妨害を受けることになる。

Q14. 1.55μm帯の光増幅に用いられる希土類添加光ファイバについて、添加される希土類は次のうちどれか

  • プラセオジム
  • ツリウム
  • (正解)エルビウム
  • イッテルビウム

解説

80-100kmを超す長距離伝送では、送信端や中継区間で光ファイバ増幅器が利用される。中でも希土類を光ファイバに添加して特定の波長帯を増幅させるアンプがあり、本問題では1.55μm帯を増幅させるためにはどの希土類を添加すべきか問うた。プラセオジムは1.3μ帯、ツリウムは1.4μ帯、イッテルビウムは1.0μ帯の増幅に適している。補足すると、エルビウムは0.85μ帯、ツリウムは2μ帯の増幅も可能である。

Q15. レイヤ3スイッチについて述べた次の文章のうち、正しいものはどれか

  • PPPoEなどのWANプロトコルに対応している。
  • ポート番号を見てトラフィックのロードバランスを行うことができる。
  • (正解)一般的にTCP/IPオンリーのネットワークで利用される。
  • RIPやOSPFなどのルーティングプロトコルを利用することができない。

解説

選択肢1として、PPPoEなどのWANプロトコルが利用できるのはルータである。選択肢2として、ポート番号を見ることができるのはレイヤ4以上の装置である選択肢4として、レイヤ3スイッチはRIPやOSPFを利用することができる(ただし装置ベンダのライセンスによる)。よって選択肢3が正解である。

Q16. BGPについて述べた次の文章のうち、誤っているものはどれか

  • BGPは、ルーティングプロトコルをその適用範囲によってIGPとEGPに分類した場合、EGPとして区分される。
  • BGPは、AS(自律システム)間の経路制御を行うためのプロトコルである。
  • (正解)BGPは、リンクステート型のルーティングプロトコルである。
  • BGPの経路制御情報は、それぞれのASにあるBGPスピーカとよばれるルータ間で交換される。

解説

選択肢3として、リンクステート型のルーティングプロトコルである点が誤っており、正しくはパスベクタ型である。

Q17. 無線のMIMO技術について述べた次の文章のうち、誤っているものはどれか

  • MIMOでは、送信側と受信側の双方に複数のアンテナを用いることによって、空間多重伝送による伝送容量の増大、ダイバーシティによる伝送品質の向上を図ることができる。
  • 空間多重された信号は、複数の受信アンテナで受信後、チャネル(伝送路)情報を用い、信号処理により分離することができる。
  • (正解)MIMOでは、水平偏波は用いることができない。
  • 複数のアンテナを近くに配置するときは、相互結合による影響を考慮する。

解説

選択肢3として、MIMOでも水平偏波を利用することができる。それ以外の選択肢の内容は正しい。

Q18. VPNについて述べた次の文章のうち、誤っているものはどれか

  • VPWS(Virtual Private Wire Service)は、MPLSの基本接続単位であるポイントツーポイント接続によるVPN接続法で、加入者から見るとMPLSネットワークを仮想回線とみなすことができる。
  • VPLS(Virtual Private LAN Service)は、3つ以上の加入者ネットワークのサイトをフルメッシュで繋ぐVPN接続法で、複数のLSP(Label Switched Path)を組み合わせることで実現している。
  • (正解)MPLSの概念を光ネットワークやSDH/SONETなどに応用したMPLS-TPでは、光信号の波長を基にルーティングを決定するとともに、制御専用のIPチャネルを用意することにより実データを光信号のままルーティングすることができる。
  • PBB(Provide Backbone Bridge)は、広域イーサネットの拡張技術であり、広域イーサネットサービス利用者の収容容量の増と負荷低減を同時に実現できる。

解説

選択肢2として、光信号のままパケットフォワーディングができるのはGMPLSであり、誤っている。

Q19. モバイルネットワークで利用されるAPNについて述べた次の文章のうち、正しいものはどれか

  • APNはドメイン名と同じ意味である。
  • どの携帯電話基地局に接続するか指定するために利用する。
  • (正解)接続先のパケットゲートウェイを指定するために利用する。
  • 端末の所属するキャリアを明確に示すために利用する。

解説

APN(Access Point Name)とは、モバイルネットワークにおいて携帯電話パケットの出入り口となるゲートウェイ(PDN-GW)を指定する識別子である。昨今MNO(携帯電話基地局を持つ携帯電話事業者)の網に接続して事業を行うMVNO事業者が増えてきているが、裏ではMVNO事業者毎にパケットゲートウェイを持ち、APNを設定する。このAPNにより、同じdocomoネットワークを利用していても、正しく接続するMVNOのネットワークを制御することができ、MNOの相乗りが可能となる。

Q20. 光ファイバケーブルの特性などについて述べた次の文章のうち、正しいものはどれか

  • 光ファイバケーブルは、布設時に加えられる曲げによって破断寿命を縮める場合がある。布設時の許容曲率半径はケーブル外径の4-5倍、固定時は6-10倍とされている。
  • 光ファイバ芯線は、温度・機械特性を満足するために、多層被覆が施されている。外装被覆は側圧保護用に柔らかい材料が、内層被覆にはマイクロベンド防止用の硬い素材が用いられている。
  • (正解)光ファイバケーブルの許容伸び率は、一般的に0.2%程度とされており、テンションメンバなどで引張強度が確保されている。
  • 光ファイバケーブルの特性試験であるしごき試験は、ローラーで500Nの側圧荷重をかけ、その際に生ずる伝送損失の変化を測定する。試験後の残留歪量も評価対象である。

解説

選択肢1として、布設時の曲げ半径は外径の20倍以上、固定時の曲げ半径は外径の10倍以上とされている。。選択肢2として、外装被覆が硬く、内装被覆が柔らかい。選択肢4として、試験後に評価されるのは残留歪量ではなく残留損失増加量である。